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Getting Started
Welcome to Learn Adobe Illustrator CC for Graphic Design and Illustration, Second 

Edition! We use a combination of text and video to help you learn the basics of 

working in Adobe Illustrator CC. We introduce you to each skill in the context of a 

hands-on project. Be sure to watch the video and download the lesson files to fol-

low along. In addition, we cover other areas that you will need to master to work 

as a graphic designer or illustrator, including how to work with clients and how to 

approach design.

About This Product
Learn Adobe Illustrator CC for Graphic Design and Illustration was created by a team 

of expert instructors, writers, and editors with years of experience in helping begin-

ning learners get their start with the cool creative tools from Adobe. Our aim is not 

only to teach you the basics of the art of graphic design and illustration with Illus-

trator but to give you an introduction to the associated skills (like design principles 

and project management) that you’ll need for your first job.

We’ve built the training around the objectives for the Graphic Design and Illus-

tration Using Adobe Illustrator CC (2018) Adobe Certified Associate Exam. If you 

master the topics covered in this book and video, you’ll be in good shape to take 

the exam. But even if certification isn’t your goal, you’ll still find this training will 

give you an excellent foundation for your future work in visual design. To that end, 

we’ve structured the material in the order that makes the most sense for beginning 

learners (as determined by experienced classroom teachers), rather than following 

the more arbitrary grouping of topics in the ACA Objectives.

To aid you in your quest, we’ve created a unique learning system that uses video 

and text in partnership. You’ll experience this partnership in action in the Web Edi-

tion, which lives on your Account page at peachpit.com. The Web Edition contains 

8 hours of video—the heart of the training—embedded in an online eBook that 

supports the video training and provides background material. The eBook mate-

rial is also available separately for offline reading as a printed book or an eBook in 

a variety of formats. The Web Edition also includes hundreds of interactive review 

questions you can use to evaluate your progress. Purchase of the book in any format 

entitles you to free access to the Web Edition (instructions for accessing it follow 

later in this section).



Most chapters provide step-by-step instructions for creating a specific project or 

learning a specific technique. Many chapters include several optional tasks that let 

you further explore the features you’ve already learned. Chapters 7 and 8 acquaint 

you with other skills and concepts that you’ll come to depend on as you use the 

software in your everyday work. Here is where you’ll find most of the coverage of 

Domain 1 of the ACA Objectives, which don’t specifically relate to features of Illus-

trator but are important components of the complete skill set that the ACA exam 

seeks to evaluate.

Each chapter opens with two lists of objectives. One list lays out the learning objec-

tives: the specific tasks you’ll learn in the chapter. The second list shows the ACA 

exam objectives that are covered in the chapter. A table at the end of the book 

guides you to coverage of all the exam objectives in the book or video.

Conventions Used in This Book
This book uses several elements styled in ways to help you as you work through 

the exercises.

Text that you should enter appears in bold, such as:

With the guide still selected, enter +.125 to the right of the current value of 

the X field in the Transform panel. 

Terms that are defined in the Glossary appear in bold and in color, such as:

In Illustrator CC, you use the drawing tools on the Tools panel to 

create shapes.

Links to videos that cover the topics in depth appear in the margins.

The ACA Objectives covered in the chapters are called out in the margins beside the 

sections that address them.

Notes give additional information about a topic. The information they contain is 

not essential to accomplishing a task but provides a more in-depth understanding 

of the topic.

NOTE  
After adding type on a path, you may want the type oriented to the other 
side of the path. To flip the type across the path, use the Selection tool to 
drag the middle bracket across the path.

	Video 2.3   
Adding Guides to  
a Document

  ACA Objective 2.1
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Operating System Differences
In most cases, Illustrator works the same in both Windows and macOS. Minor plat-

form-specific differences do exist between the two versions, such as keyboard short-

cuts, how dialog boxes are displayed, and how buttons are labeled. In most cases, 

screenshots were made in the Mac version of Illustrator and may appear somewhat 

differently from your own screen.

Where specific commands differ, they are noted within the text as follows:

Save your progress by pressing Command+S (macOS) or Ctrl+S (Windows).

In general, the Windows Ctrl key is equivalent to the Command key in macOS, and 

the Windows Alt key is equivalent to the Option key in macOS.

As lessons proceed, instructions may be truncated or shortened to save space, with 

the assumption that you picked up the essential concepts earlier in the lesson. For 

example, at the beginning of a lesson you may be instructed to “press Command+C 

(macOS) or Ctrl+C (Windows).” Later, you may be told to “copy” text or a graphic 

element. These should be considered identical instructions.

If you find you have difficulties in any particular task, review earlier steps or exer-

cises in that lesson. In some cases, if an exercise is based on concepts covered 

earlier, you will be referred to the specific lesson.

Installing the Software
Before you begin using Learn Adobe Illustrator CC for Graphic Design and Illustration, 

make sure that your system is set up correctly and that you’ve installed the proper 

software and hardware. This material is based on the original 2018 release of Adobe 

Illustrator CC (version 22) and is designed to cover the objectives of the Adobe 

Certified Associate Exam for that version of the software.

The Adobe Illustrator CC software is not included with this book; it is available 

only with an Adobe Creative Cloud membership, which you must purchase, or 

it must be supplied by your school or other organization. In addition to Adobe 

Illustrator CC, some lessons in this book have steps that can be performed with 

Adobe Bridge CC and other Adobe applications or web services such as Typekit.  

You must install these applications from Adobe Creative Cloud onto your com-

puter. Follow the instructions provided at helpx.adobe.com/creative-cloud/help/ 

download-install-app.html.

Getting Started  xi
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ADOBE CREATIVE CLOUD DESKTOP APP

In addition to Adobe Illustrator CC, this training requires the Adobe Creative Cloud 

desktop application, which provides a central location for managing the dozens of 

apps and services that are included in a Creative Cloud membership. You can use 

the Creative Cloud desktop application to sync and share files, manage fonts, access 

libraries of stock photography and design assets, and showcase and discover cre-

ative work in the design community.

The Creative Cloud desktop application is installed automatically when you down-

load your first Creative Cloud product. If you have Adobe Application Manager 

installed, it auto-updates to the Creative Cloud desktop application.

If the Creative Cloud desktop application is not installed on your computer, you 

can download it from the Download Creative Cloud page on the Adobe website 

(creative.adobe.com/products/creative-cloud) or the Adobe Creative Cloud desktop apps 

page (www.adobe.com/creativecloud/catalog/desktop.html). If you are using software 

on classroom machines, be sure to check with your instructor before making any 

changes to the installed software or system configuration.

CHECKING FOR UPDATES

Adobe periodically provides updates to software. You can easily obtain these 

updates through the Creative Cloud. If these updates include new features that 

affect the content of this training or the objectives of the ACA exam in any way,  

we will post updated material to peachpit.com.

Accessing the Free Web 
Edition and Lesson Files
Your purchase of this product in any format includes access to the corresponding 

Web Edition hosted on peachpit.com. The Web Edition contains the complete text 

of the book augmented with hours of video and interactive quizzes.

If you purchased an eBook from peachpit.com or adobepress.com, the Web Edition 

will automatically appear on the Digital Purchases tab on your Account page. Click 

the Launch link to access the product. 

Continue reading to learn how to register your product to get access to the 

lesson files.

TIP  
You’ll find a video 
walkthrough of 
these instructions at 
www.peachpit.com/
LearnACAillustrator.
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If you purchased an eBook from a different vendor or you bought a print book, you 

must register your purchase on peachpit.com:

1	 Go to www.peachpit.com/register.

2	 Sign in or create a new account.

3	 Enter ISBN: 9780134878386.

4	 Answer the questions as proof of purchase.

5	 The Web Edition will appear under the Digital Purchases tab on your Account 

page. Click the Launch link to access the product.

To work through the projects in this product, you will first need to download the 

lesson files from peachpit.com. You can download the files for individual lessons or 

download them all in a single file.

The Lesson Files can be accessed through the Registered Products tab on your 

Account page. Click the Access Bonus Content link below the title of your product 

to proceed to the download page. Click the lesson file links to download them to 

your computer.

Project Fonts
All fonts used in these projects are either part of standard system installs or can 

be downloaded from Typekit, an Adobe web service that is included with your 

Creative Cloud membership. If you don’t have the fonts mentioned in the video, 

you can install them or explore the fonts you have available on your system if this 

is not an option. 

Additional Resources
Learn Adobe Illustrator CC for Graphic Design and Illustration is not meant to replace 

documentation that comes with the program or to be a comprehensive reference 

for every feature. For comprehensive information about program features and 

tutorials, refer to these resources:

Adobe Illustrator CC Learn & Support: helpx.adobe.com/illustrator.html is where 

you can find and browse Help and Support content on Adobe.com. Adobe 

Illustrator Learn & Support are accessible from the Help menu in Illustrator.  

Help is also available as a printable PDF document. Download the document at 

https://helpx.adobe.com/pdf/illustrator_reference.pdf.

Getting Started  xiii
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Adobe Forums: forums.adobe.com/community/illustrator lets you tap into peer-to-peer 

discussions, questions, and answers on Adobe products.

Adobe Illustrator CC product home page: adobe.com/products/illustrator provides 

information about new features and intuitive ways to create professional-quality 

videos that play back on a wide range of devices.

Adobe Exchange: www.adobeexchange.com is a central resource for finding tools, 

services, extensions, code samples, and more to supplement and extend your 

Adobe products.

Resources for educators: adobe.com/education and edex.adobe.com offer a trea-

sure trove of information for instructors who teach classes on Adobe software at 

all levels.

Adobe Certification
The Adobe training and certification programs are designed to help video editors, 

designers, and other creative professionals improve and promote their product-

proficiency skills. The Adobe Certified Associate (ACA) is an industry-recognized 

credential that demonstrates proficiency in Adobe digital skills. Whether you’re 

just starting out in your career, looking to switch jobs, or interested in preparing 

students for success in the job market, the Adobe Certified Associate program is for 

you! For more information visit edex.adobe.com/aca.

Resetting the Preferences to 
Their Default Settings
Illustrator lets you determine how the program looks and behaves (like tool set-

tings and the default unit of measurement) using the extensive options in Edit > 

Preferences (Windows) or Illustrator CC > Preferences (macOS). To ensure that the 

preferences and default settings of your Adobe Illustrator program match those 

used in this book, you can reset your preference settings to their defaults. If you are 

using software installed on computers in a classroom, don’t make any changes to 

the system configuration without first checking with your instructor.
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To reset your preferences to their default settings, follow these steps:

1	 Quit Illustrator.

2	 Hold down the Cmd+Option+Shift keys (macOS) or Ctrl+Alt+Shift keys 

(Windows).

3	 Continue to hold the keys and start Adobe Illustrator CC.

When Illustrator finishes launching, you’ll see that your Preferences settings 

have been reset to their default values.

Getting Started  xv



CHAPTER OBJECTIVES

Chapter Learning Objectives
�� Place photos into an Adobe Illustrator file.

�� Use the Shape Builder tool to create 
artwork.

�� Work with text in Illustrator.

�� Understand color mode settings for  
web documents.

�� Save files for web use.

�� Use Export For Web and Export  
For Screens.

Chapter ACA Objectives
For full descriptions of the objectives,  
see the table on pages 196–204.

DOMAIN 2.0   
PROJECT SETUP AND INTERFACE

2.1a, 2.4

DOMAIN 3.0   
ORGANIZATION OF DOCUMENTS

3.1

DOMAIN 4.0   
CREATE AND MODIFY VISUAL ELEMENTS

4.1, 4.1a, 4.2, 4.4, 4.5b, 4.6c

DOMAIN 5.0   
PUBLISHING DIGITAL MEDIA

5.1a, 5.2, 5.2b



CHAPTER 6

Creating and 
Exporting Content 
for Web and 
Mobile Projects
In this chapter you’ll create a mockup for a mobile application. Adobe 

Illustrator CC offers several advantages for this type of work, namely the 

fact that by using vector content you can easily make adjustments to ele-

ments without loss of quality. In addition, Illustrator gives us several tools 

that we can use for exporting that vector-based content to web graphics 

for use during web development.

Creating a Document 
for a Mobile Device
We’ll begin by creating a new document in Illustrator at the size of a mobile device. 

Illustrator offers several presets in the Mobile category when you are creating a 

new document. If you don’t see the mobile device size that you’re looking for, you 

can enter custom values in the Width and Height fields in the New Document 

dialog box.

1	 With Illustrator open on your computer, choose File > New or click the Create 

New button in the Start workspace to open the New Document dialog box.

  ACA Objective 2.1a

  ACA Objective 5.1a

  ACA Objective 5.2b

	Video 6.1  Creating 
an Illustrator File at 
the Size of a Mobile 
Screen
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2	 Click the Mobile category at the top of the dialog box to view all presets based 

on the Mobile profile, and select the iPhone 6 Plus preset. Click the Create 

button and save the document as Mobile Mockup.ai (Figure 6.1).

Because you’re creating a document based on a Mobile preset, the units of 

measurement are set to pixels, the color mode is set to RGB, and the Raster 

Effects resolution is set to 72 ppi.

3	 Open the Layers panel. Double-click Layer 1 and rename it Interface.

4	 Make sure the Align Art To Pixel Grid button  is selected in the Control 

panel; then select the Rectangle tool and click anywhere on the artboard. In 

the Rectangle dialog box, enter 1242 px and 200 px in the Width and Height 

fields, respectively. Click OK.

5	 Set the fill color of the Rectangle to black and the stroke to None. Move the 

rectangle to the top of the artboard and align it to the top and sides.

6	 Using the Selection tool, hold down Option (macOS) or Alt (Windows) and 

drag a copy of the rectangle to the bottom of the artboard (Figure 6.2).

Figure 6.1  Creating a new document using the specifications for a mobile device

Figure 6.2  Setting up the 
interface of the mobile 
design
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Creating the Icons for 
the Mobile Mockup
As you’re well aware by now, the major strength of Adobe Illustrator is drawing 

vector artwork. Icons most definitely fall into this category. In this chapter, you’ll 

see how Illustrator makes this process relatively easy. Beginning with some basic 

shapes, we’ll create some useful icons for this project. 

Creating the Hamburger Icon 
for the Mobile Mockup
The mockup for our mobile application uses a few unique icons that we need to 

create for the design of this piece. It’s useful to know that you can also download 

existing art by selecting a template in the New Document dialog box or by down-

loading artwork from stock.adobe.com (purchase required for access to stock photos 

and artwork).

1	 Open the Layers panel.

2	 Create a new layer called Icons on which you’ll be drawing the icons for the 

mobile mockup.

3	 Using the Line tool, drag to draw a short horizontal line about 150 px long 

in the upper-left corner of the mobile interface. In the Stroke panel, set the 

stroke weight to 20 px and select Round for the cap. In the Color panel, set 

the stroke color to 156 Red, 193 Green, and 0 Blue.

As stated before, it’s a good idea to add this color to your Swatches panel and 

set that swatch to be a global color. That way, it’s easy to reuse the color later, 

and if you should decide that you want a different color, you can edit the 

swatch and every object with that swatch applied to it will update instantly.

4	 Using the Selection tool, Option-drag (macOS) or Alt-drag (Windows) the line 

to make a copy. While dragging, add the Shift key to keep the copy of the line 

aligned with the original line. Release the mouse to create the aligned copy.

5	 Press Command+D (macOS) or Ctrl+D (Windows) to repeat the last transfor-

mation so that you have a total of three lines stacked on top of one another, 

creating the hamburger icon (Figure 6.3).

  ACA Objective 4.1a

  ACA Objective 4.4

  ACA Objective 4.5b

  ACA Objective 4.6c

	Video 6.2  Creating 
the Icons for the 
Mobile Mockup

Figure 6.3  Drawing the 
hamburger icon for the 
mockup
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Drawing the Icons at the 
Bottom of the Mockup
Like most mobile applications, ours uses a row of unique icons at the bottom of the 

interface. Let’s draw those icons now.

DRAWING THE FAVORITES ICON

1	 Using the Star tool, click once on the artboard to display the Star dialog box. 

Enter 80 px for Radius 1, 40 px for Radius 2, and 5 for Points. Click OK to 

create the Star.

2	 Position the star on top of the black rectangle at the bottom of the interface, 

set the fill color to the green color swatch that you created earlier in the chap-

ter, and set the stroke color to None.

DRAWING THE LOCATION ICON

1	 Using the Ellipse tool, draw a circle that is about 75 px in diameter. Fill this 

shape with the green swatch.

2	 Switch to the Pen tool and Option-click (macOS) or Alt-click (Windows) on 

the bottom anchor point of the shape to convert the smooth anchor point to 

a corner point.

3	 Hold down Command (macOS) or Ctrl (Windows) to temporarily access the 

Direct Selection tool. Drag the bottom anchor point down until this icon is 

the same size as the star shape (Figure 6.4).

4	 Draw a smaller circle on top of this shape and position it in the center but 

toward the top of the larger shape.

5	 Select both of the shapes and choose Object > Compound Path > Make.

DRAWING THE HEART

This technique is a great example of achieving the desired result using a method 

that you might not expect would produce that result.

1	 Using the Rectangle tool, draw a square and then rotate the square shape 

45 degrees.

2	 Draw another rectangle that overlaps the square covering the top but reveal-

ing a triangle shape at the bottom.

Figure 6.4  Dragging the 
anchor point down to 
reshape the object
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3	 Select both shapes; then select the Shape Builder tool. Hold down Option 

(macOS) or Alt (Windows) and click the top two shapes, leaving only the 

triangle shape remaining at the bottom (Figure 6.5).

	

4	 Using the Direct Selection tool, click the top line segment of the triangle to 

select it, and then press Delete or Backspace to delete the top line segment, 

leaving an open path that is still the same shape.

5	 Set the stroke color to the green swatch we saved earlier and the fill color to 

None. In the Stroke panel, set the cap to round and increase the stroke weight 

until the triangle looks like a heart shape.

6	 Choose Object > Expand. Select Fill and Stroke and click OK. Scale the heart 

shape to the desired size.

DRAWING THE ADD ICON

We don’t have to reinvent the wheel to draw this icon. As a matter of fact, if you 

wanted to, you could grab the Type tool, type a + character, pick a font that you 

like, and just convert it to outlines. There’s no wrong way to do this! Explore, enjoy, 

be creative! We’ll take a more primitive approach and draw the Add icon using 

some basic shapes.

1	 Using the Rectangle tool, draw a rectangle that is tall and skinny but the 

height of the other icons at the bottom of the interface.

2	 With the rectangle selected, choose Edit > Copy, and then Edit > Paste In 

Front to put a duplicate copy right on top of the first one.

Figure 6.5  Using the 
Shape Builder tool to 
produce a small triangle
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3	 Rotate the copy of the rectangle 90 degrees based on the center of the shape.

4	 Select both rectangles and drag across the shapes using the Shape Builder tool 

to merge the two shapes into one (Figure 6.6).

DRAWING THE INFO ICON

The last icon we have to draw is the Info icon. You see this in a lot of apps; it’s the 

icon that people tap when they want to know more information.

1	 Using the Ellipse tool, draw a perfect circle that is the height of the other 

icons. Fill this circle with the green color as well.

2	 Using the Type tool, click once on the artboard to create a point type object 

and type the letter i. Adjust the font and size of the i so that it fits within 

the circle.

3	 Select the i character using the Selection tool and choose Type > Create 

Outlines.

4	 Position and size the i character inside the circle. Select the character and the 

circle, and then choose Object > Compound Path > Make. This punches the 

i character through the circle shape (Figure 6.7).

	

Figure 6.7  Creating a compound 
path for the Info icon

5	 Distribute the space between the icons at the bottom of the document by 

positioning the left- and rightmost icons where you want them. Then select 

all of the icons and click the Horizontal Distribute Space icon  at the bot-

tom of the Align panel.

Figure 6.6  Using the 
Shape Builder tool to 
merge the two rectangles 
together
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THE PATHFINDER PANEL

Although this chapter and the accompanying videos use the Shape Builder 
tool to create new shapes from existing shapes, the tried-and-true Path-
finder panel can also be used to achieve the same result. At the top of the 
Pathfinder panel, you’ll find buttons that activate four different shape modes, 
each of which performs a different action based on the stacking order of 
the selected objects (Figure 6.8). The stacking order of the objects is very 
important when using the Pathfinder panel, so if you don’t get the result 
you’re expecting, oftentimes adjusting the stacking order will address the 
problem.

Figure 6.8  The 
Pathfinder panel

The Shape Mode buttons in the top row of the Pathfinder panel are

�� Unite: Combines the selected objects into an object

�� Minus Front: Removes the overlapping objects from the bottom shape

�� Intersect: Removes everything except where all of the selected over-
lapping objects intersect

�� Exclude: Similar to Intersect except the overlapping area of two 
objects is removed, leaving everything else intact

In our mockup, you could have used Unite to make the plus icon, and Minus 
Front to create the Heart and Info icons.

It’s worth noting that you can also use these shape modes to produce edit-
able effects by holding down Option (macOS) or Alt (Windows) while click-
ing a shape mode button. Shapes created this way are called compound 
shapes.

Not to be overlooked, the bottom row of buttons in the Pathfinder panel 
allow you to apply Pathfinder operations as effects. Pathfinder effects can be 
applied to any combination of objects, groups, or layers. 

Pathfinder operations can also be applied from the Effect > Pathfinder menu 
but can be used only on groups, layers, and text objects. See the Illustrator 
User Guide at https://helpx.adobe.com/illustrator/user-guide.html for more 
information.
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Adding Text and Photos
In this section, we’ll add the finishing touches to the project by adding some text 

and photographic elements to represent the appearance of the app in its final form.

1	 In the Layers panel, create a new layer called Photo Elements. This is where 

you’ll put the imagery for the design.

2	 Choose File > Place and navigate to your exercise files folder and select the file 

called Butterfly.psd. Make sure that Link is selected, and then click Place. 

Position the subject of the photo in the main area of the app between the top 

and bottom rectangles in the document.

3	 Temporarily hide the photo, and using the Rectangle tool, draw a rectangle in 

the main area of the artboard between the rectangles located at the top and 

bottom of the page.

4	 Make the photo visible, and using the Selection tool, select the photo and the 

rectangle and choose Object > Clipping Mask > Make. You’ve made a clipping 

mask that clips the placed image to the bounds of the rectangle (Figure 6.9).

Creating the Divisions of the Main Screen
On the main screen of the mobile site, there will be three sections that a user can 

tap to navigate to a particular area of the site. In this section we’ll create those sec-

tions by simulating the appearance of the main screen being divided into three 

different areas.

1	 Using the Rectangle tool, drag out another rectangle the size of the main 

screen. This should be the exact same size as the previous rectangle that 

you drew.

2	 With the rectangle selected, open the Transform panel and deselect the 

Constrain Width And Height Proportions icon so you can adjust the width 

and height of the object independently. Now click one of the top points of 

the Reference point icon  and in the height (H) field, type /3 after the cur-

rent value. This sets the height of the rectangle to 1/3 of the original height.

3	 Hold down Option (macOS) or Alt (Windows) and drag to create a copy of the 

rectangle below the current one. Be sure to align the top of the copy to the 

bottom of the original rectangle. Fill the rectangle with black.

  ACA Objective 3.1

  ACA Objective 2.4

  ACA Objective 4.2

	Video 6.3  Adding 
Text and Images to 
the Mobile Mockup

Figure 6.9  Placing the 
Butterfly.psd photo 
in position on the mockup 
and cropping it with a clip-
ping mask
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4	 Make another copy of the rectangle and position it below the 

second rectangle to create a third rectangle. Fill this one with 

black as well.

5	 Select the second rectangle and open the Transparency panel.  

Set the blending mode to Color and Opacity to 70%. This  

gives the second section a desaturated look yet still with some 

color to the photo.

6	 Finally, select the third rectangle, and in the Transparency panel, 

change the blend mode to Color with an Opacity value of 100%. 

This completely desaturates the image, giving it a black and white 

appearance (Figure 6.10).

Adding Text to the Mobile Mockup
We’re almost finished with the design; we just need to add some text 

for the title of the mobile design and then some additional text for the 

individual sections of the design.

1	 Using the Type tool, click to create a point type object and type 

the text The Insectarium. Change the font to one of your choos-

ing and adjust the size to fit in the rectangle at the top of the 

screen. We used Clavo Medium at 107 pt. Change the text color 

to white.

2	 Using the Rectangle tool, drag to draw a thin rectangle that is as 

wide as the artboard and about 120 px tall. Move this rectangle to 

the bottom of the first section and set the fill color of the rectan-

gle to black and the opacity to 50%.

3	 Using the Type tool, add some point type with the text 

Butterflies and set the color to white and adjust the font and 

size to fit within the rectangle. Align the text visually within 

the rectangle.

4	 Select the text and the rectangle and duplicate them to the sec-

ond and third sections of the design. Change the text for section 

two to Insects and section three to Other (Figure 6.11).

Figure 6.10  After dividing the image 
area of the mobile mockup into three 
sections

Figure 6.11  Adding the text and 
rectangle to each of the three sections 
of the design
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Creating Web Graphics 
Using Save For Web
Now that the design of the mobile site is finished, we need to provide the web 

developers with image assets to use to produce the finished product. One way to do 

this is using the Save For Web command. This command gives users the ability to 

control how web assets are generated from the Illustrator artwork.

Creating Slices
Slices are a way to divide your artwork into individual sections, each of which can 

be formatted as an independent image and can use the format of your choosing. 

Although you can manually create slices using the Slice tool  , there are more 

accurate ways to get the job done that you’ll learn in the following steps.

  ACA Objective 4.1

  ACA Objective 5.2

	Video 6.4  Saving 
to Web-Based 
Formats Using 
the Save For Web 
Command

Figure 6.12  Creating slices for the indi-
vidual elements of the design

1	 In the Layers panel, unlock any locked layers, and using the 

Selection tool, select the rectangle at the top of the artboard.

2	 Choose Object > Slice > Make. Illustrator creates a slice at the 

top of the artboard the same size as the selected rectangle and 

creates another slice for everything else that remains on the 

artboard. 

3	 Select the rectangle that encompasses the first section of the 

main screen and choose Object > Slice > Make.

4	 Repeat steps 1 through 3 for section two and three as well as 

the rectangle at the bottom of the artboard (Figure 6.12).

Using Save For Web
Now that we have sliced the design, we can export those individual 

slices to various web formats based on the content of each slice. Web 

formats can be a bit confusing and misunderstood, so here’s a list of 

the common web formats and the preferred use for each format:

�� JPEG—The JPEG (Joint Photographic Experts Group) format 

is commonly used due to its ability to compress files to very 

small sizes. This compression is applied based on a sliding scale 

between quality and file size. It’s important to know that the 

JPEG format utilizes lossy compression, which means some 
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data is thrown away when saving to this format. How much data is discarded 

depends on the quality/size slider setting that is used. The JPEG format is best 

used for continuous tone images (photographs).

�� GIF—The GIF (Graphics Interchange Format) format is best used for artwork 

that contains areas of solid color, such as text and logos (not photographs). 

One of the advantages of the GIF format is its ability to include transparency 

in the image. This is useful for removing the background color of artwork so 

that it can be used on any background color that you choose when placing it 

in a web page.

�� PNG-8—The PNG-8 (Portable Network Graphics) format is similar to the GIF 

format. Both work best with images that have blocks of color (as opposed 

to continuous tone images) and that contain a limited number of colors 

(“8‑bit color”). Because PNG-8 compresses files more efficiently than GIF, it’s 

gained popularity now that browser support is widespread. Another advan-

tage is that PNG-8 can include multilevel transparency for elements such as 

drop shadows.

�� PNG-24—The PNG-24 format shares many of the advantages of PNG-8 

including support for continuous tone images (“24-bit color”). It’s become 

quite popular as a replacement for the JPEG format because it can contain 

multilevel transparency for elements such as drop shadows, whereas the JPEG 

format doesn’t support transparency at all. Also, both PNG formats use loss-

less compression, so no data is lost with reduced file sizes.

�� SVG—The SVG (Scalable Vector Graphics) format is the only vector format 

of all the formats in this list. In the advent of adaptive and responsive web 

design, the ability to scale vector graphics is a huge advantage for designers 

and developers.

There are multiple methods for exporting web image assets from Illustrator. 

The traditional method uses the Save For Web command. In recent versions of 

Illustrator, the word legacy has been added to this command to indicate that there’s 

a newer feature (covered later in this chapter) that offers some advantages.

1	 Choose File > Export > Save For Web (Legacy). The Save For Web dialog 

box opens.

2	 Using the Slice tool in the Save For Web dialog box, you can click each slice 

to select it and then choose an export format for the selected slice in the right 

side of the dialog box.
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You can choose the format and settings for each slice, but you can also choose 

a preset from the Name menu in the Preset area in the upper right of the dia-

log box. You can specify pixel dimensions in the Image Size area if you need a 

size other than what is defined on the artboard.

3	 Click the slices at the top and bottom of the artboard and choose PNG-8 128 

Dithered from the Name menu.

4	 Click the remaining slices and choose PNG-24 from the Name menu. You can 

Shift-click to select multiple slices at the same time (Figure 6.13).

5	 Click Save and choose a location in which the images will be saved. Click the 

second Save button to save the images.

Figure 6.13  Defining the 
output formats of the indi-
vidual slices in the Save 
For Web dialog box
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Using Export for Screens to 
Generate Web and Mobile Assets 
The Save For Web command works well, but if you need to export individual ele-

ments of your design, it isn’t much help. Fortunately, Illustrator has the Save For 

Screens command, which makes it easy to get more granular with your design ele-

ments and export exactly the items that you need at the size and in the format(s) 

that you need them.

1	 Choose View > Hide Slices to hide the slices that you defined in the previous 

section.

2	 Choose File > Export > Export For Screens. In the Export For Screens dialog 

box (Figure 6.14), notice that selecting the Artboard tab at the top allows you 

to export each artboard in your document as an individual file.

The section on the right side of the Export For Screens dialog box gives you 

the ability to choose the range of artboards you want to export as well as the 

location of the exported files. You can also add scale factors, which will create 

additional images of each artboard at the scale factor and in the format that 

you desire.

3	 Click the Export Artboard button to export the artboard assets.

  ACA Objective 5.2

	Video 6.5  Using 
Export for Screens 
to Create Assets  
for Web and  
Mobile Use

Figure 6.14  Exporting the 
artboards using the Export 
For Screens dialog box
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Exporting Individual Assets
1	 Choose File > Export > Export For Screens to display the Export For Screens 

dialog box. Click the Assets tab at the top of the dialog box; then click the 

Asset Export Panel button in the middle of the Assets tab.

You can also get to the Asset Export panel by choosing Window > Asset 

Export.

2	 Select the Favorite icon at the bottom of the mockup and drag it to the Asset 

Export panel. The artwork is added to the panel. Click the name to highlight 

it and assign a more appropriate name if desired. Repeat for the remainder of 

the icons at the bottom of the mockup.

Figure 6.15  Assets added to 
the Asset Export panel

3	 Select the three lines that make up the hamburger icon at the top left of 

the design and drag them to the Asset Export panel. Whoops! Each line 

got added individually to the panel. Good to know in the future, but not 

what we want! Choose Edit > Undo. Now, hold Option (macOS) or Alt 

(Windows) and drag the lines to the Asset Export panel. This time, all of 

the items are added as a single asset (Figure 6.15).

4	 If desired, click the Add Scale button to add an additional size for each 

of the assets in the Asset Export panel. When doing so, you can define a 

scale factor, suffix, and format for the additional asset.

5	 Choose File > Export > Export For Screens. In the Export For Screens 

dialog box, click the Assets tab. Each icon from the Asset Export panel 

is shown with the same options available for format and scaling that 

we saw previously. Select each asset that you wish to export or select All 

Assets to export all assets.

6	 Click the Export Asset button to export all the assets selected in the 

Export For Screens dialog box.

7	 Choose File > Save to save the document and File > Close to close it.

Congratulations! You finished the chapter! Understanding how to create 

content in Illustrator and how to generate web images from that artwork will 

serve you well in your design career. Print and web continues to coexist and 

overlap in many different areas, and having the knowledge to work with both 

is a huge asset. Keep it up!
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